오픈카트 페이팔

Paypal (페이팔) security header is not valid 에러 발생시

오픈카트에서 페이팔 테스트 중에  security header is not valid 에러가 발생하였다. 이런경우에 다음과 같이 하면 해결된다. /catalog/model/payment/pp_express.php 파일에 아래 코드를 넣어야 함. CURLOPT_SSLVERSION => 6,   $defaults = array( CURLOPT_POST => 1, CURLOPT_HEADER => 0, CURLOPT_URL => $api_endpoint, CURLOPT_USERAGENT => "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1", CURLOPT_FRESH_CONNECT => 1, CURLOPT_RETURNTRANSFER => 1, […]

Scroll to top